Back to overview
Resolved

Partial network outage

Jul 29, 2026 at 3:47pm UTC
Affected services
Digital Realty AMS5 - Amsterdam

Resolved
Jul 29, 2026 at 3:57pm UTC

Update – Resolved

The incident has been fully resolved, and all affected services are operating normally.

During a scheduled maintenance activity, an unexpected issue caused a partial network outage affecting a limited number of racks at our Digital Realty AMS5 location. Depending on the affected rack, the interruption lasted approximately 5–10 minutes.

The root cause has been identified, and corrective measures have been implemented to prevent this from occurring again. In addition, we have updated our internal procedures to ensure that all planned maintenance activities, regardless of expected impact, will be communicated in advance via our status page going forward.

We sincerely apologize for the inconvenience and appreciate your patience and understanding.

Created
Jul 29, 2026 at 3:47pm UTC

We're investigating a partial network outage affecting some racks at our DigitalRealty AMS5 location.