Back to overview
Downtime

NYC02 DDoS Attack

Jul 27, 2025 at 08:22pm UTC
Affected services
VPS Node 2 NYC

Resolved
Jul 27, 2025 at 08:34pm UTC

The issue has been resolved.

Created
Jul 27, 2025 at 08:22pm UTC

NYC02 is currently receiving a DDoS attack which is causing degraded performance. Our team is working hard to restore it's performance.