Back to overview
Downtime

Network Issues New York

Jul 25 at 10:30am CEST
Affected services
Evocative EWR1 - New York

Resolved
Jul 25 at 11:25am CEST

The emergency maintenance at the upstream provider has been completed.

Created
Jul 25 at 10:30am CEST

We are currently experiencing a problem with our network in New York. This is due to an emergency at the upstream provider. The ETA for this is 30 minutes.