Back to overview

Detected network performance issues

Sep 27 at 11:58pm CEST
Affected services
Equinix AM5 - Amsterdam
Evocative EWR1 - New York

Resolved
Sep 28 at 12:48am CEST

The network seems more stable now, we are still extensively monitoring the network.

Created
Sep 27 at 11:58pm CEST

Our network is currently under extremely high load and we are investigating the issues, we will post updates here asap.