Back to overview

Degraded network performance

Sep 13 at 09:30pm CEST
Affected services
Equinix AM5 - Amsterdam

Resolved
Sep 13 at 09:30pm CEST

We are currently experiencing an extremely high load on our network, this might cause packet loss.

Update 22:31 CEST:
Issues have been resolved and we will actively keep monitoring the network, some packet loss might have been experienced while these issues where ongoing.